On https://softwarerecs.stackexchange.com/tour I found two links, one that links to

https://meta.softwarerecs.stackexchange.com/questions/336/what-is-required-for-a-question-to-contain-enough-information (with the link text "question quality guidelines")

and another that links to:

https://meta.softwarerecs.stackexchange.com/questions/356/what-is-required-for-an-answer-to-be-high-quality (with the link text "answer quality guidelines")

Visiting these links (latest Chrome, latest Win10) causes a NET::ERR_CERT_COMMON_NAME_INVALID error. If I then remove the https:// part of the urls and try again I get forwarded from meta.softwarerecs.stackexchange.com to softwarerecs.meta.stackexchange.com.

The links should (probably) direct the user to their softwarerecs.meta.stackexchange.com equivalent.

The redirect from meta.softwarerecs.stackexchange.com to softwarerecs.meta.stackexchange.com should work without the NET::ERR_CERT_COMMON_NAME_INVALID error.

  • It does. I just tried the two links, work fine for me. Tried on Waterfox Classic, Waterfox G3 and the latest Chromium – on Linux (MS free zone here). What's more, I checked with the tour page, and the links are going directly to softwarerecs.meta,stackexchange.com (meta.softwarerecs.stackexchange.com was replaced years ago to ease the handling of certificates). So as I followed all the links from your question, it's unclear to me how you are getting where/what you said.
    – Izzy Mod
    Commented Feb 7, 2022 at 23:06
  • @Izzy I tried it in Firefox, Chrome and even Edge (yuck). Even after clearing the cache (Ctrl-Shift-R and Ctrl-F5) I still have the same problem. Disabling Ublock didn't seem to chance anything. What can I do to show you the problem?
    – user76494
    Commented Feb 7, 2022 at 23:46
  • I've no idea. I cannot reproduce it, and the links do not even look like you describe – so I do not see what we could "fix". I'd almost blame it on something Windows-releated on your machine, but would wonder why it should rewrite URLs to what they looed 3+ years ago, just to be unable to "rewrite it back". I very much doubt the old ones still have a valid certificate (checked: so it is, which then at least explains the NET::ERR_CERT_COMMON_NAME_INVALID which definitely won't be fixed on SE's end). Can you try on a different machine?
    – Izzy Mod
    Commented Feb 8, 2022 at 8:27
  • @Izzy Chromium on Raspbian on Raspberry Pi 4 i.imgur.com/mXYoXtr.png and i.imgur.com/bHwA7ef.png and i.imgur.com/mfFrCCx.png that certificate has expired on March 3rd, 2021....
    – user76494
    Commented Feb 8, 2022 at 10:40
  • Same problem on Firefox 96.3.1 and Chrome 98.0.4758.87 on Android 11 (even when using mobile data).
    – user76494
    Commented Feb 8, 2022 at 10:50
  • 1
    Sorry, but I cannot reproduce that, as I wrote. Those old links have been replaced long ago. Here's the "inspect" screenshot I just took: i.sstatic.net/dYiMr.png // Just for fun I tried with Chrome on Android, and there indeed I can reproduce the issue – strange. Investing the page source directly, I indeed can find the old links.And after looking around more closely, even found out how to fix them. Can you please try again?
    – Izzy Mod
    Commented Feb 8, 2022 at 23:28
  • 1
    @Izzy That fixed it! A round of champagne for all and a statue for Izzy. Now no one has an excuse not to have read those pages! Thank you. I will throw a rotten tomato at Micro$oft HQ in your honour.
    – user76494
    Commented Feb 9, 2022 at 0:13
  • The /tour/ page is fixed, but if I go to the old links (mentioned in the post above) I still get the certificate error. So it may be a good idea to check why those redirects from meta.softwarerecs.stackexchange.com to softwarerecs.meta.stackexchange.com don't work. It is possible there are more redirects elsewhere that have the same problem.
    – user76494
    Commented Feb 9, 2022 at 0:41
  • Hm I googled site:"softwarerecs.meta.stackexchange.com" +"meta.softwarerecs.stackexchange.com" and so far they all work. // Ah I get it those are http not https. If i change them to https they fail to redirect, for example meta.softwarerecs.stackexchange.com/questions/336/…
    – user76494
    Commented Feb 9, 2022 at 0:58
  • 1
    Looks like our Lizard fixed those I've missed. Thanks for reporting! I'm still puzzled how it comes I could not reproduce it on the desktop. In my Foxes it could have been some addon/userscript – but Chromium (which I only use for video cons) I intentionally left "blank"… Well, never mind. More important is it's working for everyone now :)
    – Izzy Mod
    Commented Feb 9, 2022 at 8:30
  • 1
    PS: the certificates for those old sites won't be fixed (and to do that, you'd have to apply to staff anyway – we are only site moderators without access to that). The whole idea was to phase them out – as it's easier to have a single wildcard cert for *.meta.stackexchange.com than having to maintain hundreds of separate ones. So no way to get "those redirects" fixed other than fixing the pages pointing there…
    – Izzy Mod
    Commented Feb 9, 2022 at 8:34
  • @Izzy Thank you. Yeah that makes sense. Ideally one could simply search and replace all links using the old format but this planet is far from ideal.
    – user76494
    Commented Feb 9, 2022 at 8:38
  • That was indeed done qor all Qs & As incl. Meta – but obviously tour etc. have been missed #D
    – Izzy Mod
    Commented Feb 9, 2022 at 13:13

1 Answer 1


A few years ago, Stack Exchange changed all their meta sites from:




I've found the URLs that use the original format are not reliable.

This is a great example of why it's important to "measure twice, cut once"!

Looking at the source code for https://softwarerecs.stackexchange.com/tour, I see multiple links to URLS using http and the old hosts. Those need to be fixed in the source code for our Tour page.

Izzy made a first pass to fix them and I just completed the second pass to fix the rest of them.

Hopefully they are all fixed now. Please let us know if you find any other broken links, and we'll be sure to fix them too.

Thank you for your keen eyes and for reporting the issues!

  • There are quite a few of those links, but for me the 2 I posted above are the only ones who do not redirect correctly. Are all those links in the old format broken for you, or just those 2? Does meta.softwarerecs.stackexchange.com/questions/336/… work for you?
    – user76494
    Commented Feb 9, 2022 at 5:19
  • 1
    @Gantendo I was busy fixing all the broken links and just read your question afterwards. They should all be good now! Please let us know if you find any other broken links, and we'll be sure to fix them too. Thank you for your keen eyes! Commented Feb 9, 2022 at 5:26

You must log in to answer this question.